Major Database Outage

Incident Report for MerchantSpring

Resolved

This incident has been resolved on Dec 1st.
Posted Dec 09, 2025 - 03:43 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 15:49 UTC

Investigating

One of our core database providers is experiencing an outage, which is impacting our application’s ability to deliver data. This is an external issue, and we are actively working with the provider to expedite their resolution.

We sincerely apologize for this disruption and assure you we are doing everything possible to resolve it swiftly. We will share updates as the situation progresses. Thank you for your understanding and support during this time.
Posted Nov 18, 2025 - 15:43 UTC
This incident affected: Analytics Dashboard and Data Pipeline.